INTEGRATIONS - Cisco AS5400




Sections

1) Cisco AS5x CAS T1 Integration
2) Cisco AS5x PRI T1 Integration



Cisco AS5400 CAS T1 Integration Notes

Diagram of the integration is found below. For customers that have TDM interfaces on PBXs that rely on CAS signaling a Cisco AS5400 Gateway can be used to convert TDM T1s into SIP Trunking to the Apeiron voice network.

Common Methods of CAS RBS Signaling are:

  • E&M Wink using DTMF or MF
  • E&M Immediate using DTMF or MF

AS5400 Diagram

In the configuration example below one E&M Wink CAS T1 is provisioned on T1 port 6/0. The Dialpeers are established with preference to primary and secondary SIP IPs in the Apeiron network.

All outbound calls are routed to Apeiron via SIP. Inbound calls matching pattern 4245555555 will be routed inbound to the CAS T1.

For outbound calls because FGB E&M configuration does not allow for ANI to be passed from PBX to the Cisco, all calls will pick up the 4245555555 number as the calling number when calls route from the AS5400 to the PSTN via Apeiron.

Cisco device configuration example:

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname <hostname>
!
boot-start-marker
no boot startup-test
boot-end-marker
!
enable password 7 
!
!
resource-pool disable
no aaa new-model
spe default-firmware spe-firmware-1
!
!
ip cef
ip domain name <domain_name>
!
username <username> password 7 <password>
!
controller T1 6/0
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type e&m-fgb dtmf dnis
!
!
interface FastEthernet0/0
 description <description>
 ip address 1.1.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
!
interface Group-Async1
 no ip address
 encapsulation slip
 group-range 1/00 3/59
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 1.1.1.1
!
no ip http server
!
!
access-list 99 remark ACL-SNMP
access-list 99 permit <snmp_ip> <snmp_rmask>
!
!
!
voice-port 6/0:0
!
!
dial-peer voice 1 voip
 preference 1
 destination-pattern .
 session protocol sipv2
 session target ipv4:66.85.56.10
 dtmf-relay rtp-ne
 no vad
!
dial-peer voice 2 pots
 destination-pattern 4245555555
 direct-inward-dial
 port 6/0:0
!
!
dial-peer voice 11 voip
 preference 2
 destination-pattern .
 session protocol sipv2
 session target ipv4:66.85.57.10
 incoming called-number .
 dtmf-relay rtp-nte
 no vad
!
sip-ua 
 set sip-status 480 pstn-cause 1
!
ss7 mtp2-variant Bellcore 0
ss7 mtp2-variant Bellcore 1
ss7 mtp2-variant Bellcore 2
ss7 mtp2-variant Bellcore 3
!
line con 0
line aux 0
line vty 0 4
 login local
 transport input telnet
line 1/00 1/59
 modem InOut
line 3/00 3/59
 modem InOut
!
end
~~~bash

Need more help?

Here's how to get in touch:

By Phone

To contact us by phone, give us a call at:
888-APEIRON (273-4766)

By E-mail

For general support inquiries, e-mail us:
[email protected]